¡Bienvenid@ a Mundo Maker!

¿Quieres aprender todo sobre el RPG Maker?



Regístrate y forma parte de Mundo Maker.
Conectarse

Recuperar mi contraseña

Temas importantes
----------------------------------------
Páginas con recursos RPG Maker
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
Afiliados
Estadísticas
Tenemos 3995 miembros registrados.
El último usuario registrado es Vash-W17.

Nuestros miembros han publicado un total de 83801 mensajes en 11931 argumentos.
Navega con Google Chrome
[DESCARGA]

Problemas con UMS

 :: RPG Maker :: Ayuda RPG

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 19:41

Buenas, compañeros:
El otro día intenté usar el UMS para los diálogos y me daba problemas. Copié el código y lo pegué en un script nuevo creado en el editor de scripts, justo encima de "Main". Sin embargo, a la hora de emplearlo me da error. Lo que hago es crear un evento, ir a la tercera pestaña, pulsar donde pone "script" y meter el script que necesito (\nm[nombredelpersonaje] por ejemplo). ¿Empleo correctamente el script o hay que hacerlo de otra manera y de ahí el error?

Muchas gracias.

Edito: la versión es la XP. Sweat Sweat
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Producciones The Golden el 2017-07-04, 21:30

Envía una captura del error, por favor.
No puedo dar detalles hasta ver el error y de hecho descargar el UMS, ¿usas éste mismo?
http://www.mundo-maker.com/t1389-rmxp-universal-message-system

Si es así asegúrate antes ver en el Demo que trae si lo utilizaste de manera correcta, en las demos suele haber ejemplos de lo que se puede hacer con los scripts.
avatar
Producciones The Golden
Veterano
Veterano

0/3

Créditos 629

Gracias : 59

http://gamerprotown.jimdo.com/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por BreinLand entertainment el 2017-07-04, 21:39

Asumiendo que utilizas el sistema de CCOA...
Los códigos de \nm, \b, etc... se usan dentro de los mensajes normales.
Lo único que tienes que hacer es escribir el mensaje como harías normalmente, y poner el código delante del texto.

Por ejemplo, si quieres que salga en negrita, el nombre del personaje con ID 1, pondrías..

Hola, soy \b\n[1]\b.

Y así saldrá en negrita y el nombre del primer personaje solo la parte de tu mensaje que has puesto como tal, por lo que se vería como...

Hola, soy Pepe. <- Si no pones el segundo \b, se pondría en negrita el punto también.

Lo único que se utiliza en llamadas de script son los otros comandos como $game_system.nosequé
avatar
BreinLand entertainment
Soñador
Soñador

0/3

Créditos 196

Gracias : 44

http://breinland.tk/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 21:47



A ver si sale, es la primera vez que lo intento...

https://servimg.com/view/19729076/1


Última edición por erpks77 el 2017-07-04, 21:59, editado 2 veces
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por BreinLand entertainment el 2017-07-04, 21:54

No te preocupes, todos tenemos una primera vez para todo.

Una cosilla con las imágenes en el foro... Si utilizas Alt/Alt gr + imp pant, capturas solo la ventana activa.

Y... si pones

(img)el link de tu imágen aquí(/img) -> en vez de con ( ponlo con [

se verá directamente aquí.

¡Ánimo!
avatar
BreinLand entertainment
Soñador
Soñador

0/3

Créditos 196

Gracias : 44

http://breinland.tk/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Producciones The Golden el 2017-07-04, 21:57

Un término indefinido... pues si, me arriesgaría a decir que es lo que dice BreinLand, ya que la mayoría de scripts de mensajes se utilizan con el comando Mostrar Mensaje, mira le demo por favor XD.
avatar
Producciones The Golden
Veterano
Veterano

0/3

Créditos 629

Gracias : 59

http://gamerprotown.jimdo.com/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 22:00

BreinLand entertainment escribió:No te preocupes, todos tenemos una primera vez para todo.

Una cosilla con las imágenes en el foro... Si utilizas Alt/Alt gr + imp pant, capturas solo la ventana activa.

Y... si pones

(img)el link de tu imágen aquí(/img) -> en vez de con ( ponlo con [

se verá directamente aquí.

¡Ánimo!

Gracias por los consejos. La cosa es que está el enlace tal y como comentas, pero me sale el icono de enlace roto. Sin embargo si le doy a botón derecho-- abrir en nueva pestaña, sí que me aperece...
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 22:03

Producciones The Golden escribió:Un término indefinido... pues si, me arriesgaría a decir que es lo que dice BreinLand, ya que la mayoría de scripts de mensajes se utilizan con el comando Mostrar Mensaje, mira le demo por favor XD.

Acabo de intentarlo pero me sale el mismo error. En la línea 1024 del código aparece lo siguiente:

if c == "0"


Entiendo poco de códigos, no se si el problema es que la variable c tiene que tener algún valor...
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Producciones The Golden el 2017-07-04, 22:06

¿Utilizas el Script que te envié arriba? si no es así envía el link del que utilizas.
avatar
Producciones The Golden
Veterano
Veterano

0/3

Créditos 629

Gracias : 59

http://gamerprotown.jimdo.com/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 22:08

Producciones The Golden escribió:¿Utilizas el Script que te envié arriba? si no es así envía el link del que utilizas.

Supuestamente uso la CCOA 1.1. Paso el enlace de la página donde lo encontré:

https://www.emudesc.com/threads/aportes-de-scripts-rpg-maker.36499/#post534581


Los enlaces que me has puesto antes no funcionan, estarán caídos...
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Producciones The Golden el 2017-07-04, 22:22

El script funciona a la perfección.

SCREENS:

Lo utilizas en el comando "Mostrar mensaje".
avatar
Producciones The Golden
Veterano
Veterano

0/3

Créditos 629

Gracias : 59

http://gamerprotown.jimdo.com/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-04, 22:38

Nada, me sale lo mismo. Lo que me he dado cuenta es que el comienzo de la linea de texto no es igual en mi XP que en el tuyo:

https://servimg.com/view/19729076/2

El mío empieza con @> y el tuyo con <>. ¿Puede tener algo que ver?
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Producciones The Golden el 2017-07-04, 22:45

Si copiaste bien el script, creaste los tres gráficos necesarios ("talk1", "talk2" y "thought" en la carpeta WindowSkins) y utilizas los comandos en Mostrar mensaje no se me ocurre que error puede haber... ya te digo que utilicé éste script:
https://www.emudesc.com/threads/aportes-de-scripts-rpg-maker.36499/page-2#post-534581
La versión que aparece bajo el mensaje de Judith que dice:
"El script del UMS que habían posteado alguno está mal, el real es este:

CORRECCIÓN UNIVERSAL MESSAGE SYSTEM

Pon esto encima de main:"
avatar
Producciones The Golden
Veterano
Veterano

0/3

Créditos 629

Gracias : 59

http://gamerprotown.jimdo.com/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por BreinLand entertainment el 2017-07-05, 04:59

El @> o <> es solo por el sistema operativo de tu ordenador, y no tiene nada que ver...

De todas formas estás utilizando una versión bastante antigua del sistema UMS.

La más actual (al menos eso creo) la puedes encontrar aquí:

http://www.gdunlimited.net/forums/files/file/63-ccoas-ums-18/ <- Hay que registrarse

(La traducción tendrás que copiarla del otro link que tu pusiste, pero los comandos deberían ser los mismos)

A veces los problemas de errores se pueden solventar con una versión más actualizada, ya que pueden deberse a incompatibilidades con otros scripts, etc.

Tal como ya te ha dicho Producciones The Golden, asegurate de tener los archivos de la carpeta WindowSkins como está en la demo.
avatar
BreinLand entertainment
Soñador
Soñador

0/3

Créditos 196

Gracias : 44

http://breinland.tk/

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-07, 19:58

Perdonad por tardar en contestar, y gracias por vuestras respuestas. Probaré la versión 1.8 y os comento. Ahora estoy un poco liado, a ver si mañana puedo hacerlo.
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por erpks77 el 2017-07-07, 20:09

Ok, acabo de hacer una prueba rápida con la versión 1.8 y ahora va perfecto, muchísimas gracias por vuestra ayuda.
avatar
erpks77
Iniciado
Iniciado

0/3

Créditos 25

Gracias : 5

Volver arriba Ir abajo

Re: Problemas con UMS

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 :: RPG Maker :: Ayuda RPG

Permisos de este foro:
No puedes responder a temas en este foro.