Mundo Maker
¡Bienvenid@ a Mundo Maker!

¿Quieres aprender todo sobre el RPG Maker?



Regístrate y forma parte de Mundo Maker.
Conectarse

Recuperar mi contraseña

Temas importantes
----------------------------------------
Páginas con recursos RPG Maker
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
Afiliados
Estadísticas
Tenemos 4201 miembros registrados.
El último usuario registrado es RamaCanalla.

Nuestros miembros han publicado un total de 85260 mensajes en 12143 argumentos.

Una duda sobre el Pokémon Elite Battle System (por si alguien sabe)

Ver el tema anterior Ver el tema siguiente Ir abajo

RPG Maker XP Una duda sobre el Pokémon Elite Battle System (por si alguien sabe)

Mensaje por Natiti320 el 2017-01-14, 19:13

Hola. Esto...tengo una duda y espero que alguien me la pueda responder.
Estaba probando el Elite Battle System y, cuando probé en un combate y usé un ataque de estado (como tóxico o rizo defensa) me salía el siguiente error:


No sé si alguien sepa qué hacer en éste caso...pero si alguien sabe...bueno...que me responda y eso.
Gracias de antemano,
avatar
Natiti320
Iniciado
Iniciado

0/3

Créditos 10

Gracias : 2

Volver arriba Ir abajo

RPG Maker XP Re: Una duda sobre el Pokémon Elite Battle System (por si alguien sabe)

Mensaje por Wecoc el 2017-01-14, 21:40

Parece que salta eso porque no existe el método set_color para Bitmap.
Dado ésto se me ocurren dos posibilidades:

1. Te falta algún script requerido por el Elite Battle, más troncal, donde se defina el método set_color.

2. Creo que es ésto, pero me sorprende que no hayan detectado ese error antes: Bitmap tiene dos métodos bastante usados llamados get_pixel y set_pixel que obtienen el color de un pixel concreto, cuando hago scripts de éste tipo alguna vez me he confundido y les he puesto get_color o set_color, que no existen, por lo que luego salta un error como el tuyo y los he tenido que cambiar (como ves el nombre da a esa confusión). Si ese es el caso solo tienes que buscar los get_color / set_color del script y cambiarlos por get_pixel / set_pixel.

Búscalos en los códigos con la opción de Buscar, si solo hay uno o pocos es que fue un lapsus, si hay muchos es que te está faltando una parte importante del sistema.
avatar
Wecoc
Administrador
Administrador



Créditos 9292

Gracias : 505

Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


Permisos de este foro:
No puedes responder a temas en este foro.