Mundo Maker
¡Bienvenid@ a Mundo Maker!

¿Quieres aprender todo sobre el RPG Maker?



Regístrate y forma parte de Mundo Maker.
Conectarse

Recuperar mi contraseña

Temas importantes
----------------------------------------
Páginas con recursos RPG Maker
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
Afiliados
Estadísticas
Tenemos 4191 miembros registrados.
El último usuario registrado es Victor Inkheart.

Nuestros miembros han publicado un total de 85157 mensajes en 12122 argumentos.

Problema con engine de pasos(Vx Ace)

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema con engine de pasos(Vx Ace)

Mensaje por Dariel Lopez el 2016-11-02, 02:27

Buenas a todos y disculpen mi ignorancia sobre el tema pero quiero hacer un engine que sume los pasos del jugador en el juego para lo cual creo una variable llamada pasos y la uso en un condiciones y efectos de esta manera:
Controlar variables: [0041:pasos] = pasos
Controlar variables: [0041:pasos] += 1
Separación Condicional: Variable [0041:pasos] >= 10
Cambiar objetos: [Monomate], + 1
Controlar Interruptor: A =Encendido
Eso hace que cuando el jugador dé 10 pasos se le sume un item Monomate a su inventario, y al encender el interruptor A me manda a una página nueva en donde pongo esto:
Controlar variables: [0041:pasos] -= 10
Controlar Interruptor: A =Apagado
Eso borra los 10 pasos dados por primera vez y apaga la segunda página del evento y se supone(o supongo) que debe de reiniciar el conteo de los pasos desde cero para llegar de nuevo a 10 y que se repita el proceso de agregar un item Monomate al inventario pero lo que hace es sumar indefinidamente el item porque no se borran los pasos dados la primera vez.
¿Alguien sabe porqué no se borran los pasos al restárselos a la variable pasos?
¿O se deben de borrar de otra manera que desconozco?
Le agradezco la ayuda a quien pueda ayudarme a solucionar ese problema.
avatar
Dariel Lopez
Veterano
Veterano

0/3

Créditos 571

Gracias : 29

Volver arriba Ir abajo

Re: Problema con engine de pasos(Vx Ace)

Mensaje por Miky Joe el 2016-11-02, 05:12

Hola elax, pues aqui echandote un lazo, es algo sencillo, pero efectivo, lo que pasa en tu metodo creo es que tomastela variable y la convertiste en "pasos del sistema" y aparte esa misma variable le estuviste agregando +1, y se te hizo un bug imagino por esa razón.

lo que hice, pues el video es muy claro.


Saludos.
avatar
Miky Joe
Veterano
Veterano

0/3

Créditos 1040

Gracias : 63

Volver arriba Ir abajo

Re: Problema con engine de pasos(Vx Ace)

Mensaje por rigel2 el 2016-11-02, 07:24

mira checa este post ese mismo problema tenia yo hasta que el buen silva me echo una mano con ello
el problema esta en las variables

http://www.mundo-maker.com/t13179-ayuda-con-contador-de-pasos
avatar
rigel2
Principiante
Principiante

0/3

Créditos 927

Gracias : 33

Volver arriba Ir abajo

Re: Problema con engine de pasos(Vx Ace)

Mensaje por Dariel Lopez el 2016-11-03, 22:18

Muchas gracias a Miky Joe y a rigel2 por su ayuda con video incluido por parte de Miky Joe y ya me funciona a la perfección el engine de pasos.
Gracias de nuevo.
avatar
Dariel Lopez
Veterano
Veterano

0/3

Créditos 571

Gracias : 29

Volver arriba Ir abajo

Re: Problema con engine de pasos(Vx Ace)

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


Permisos de este foro:
No puedes responder a temas en este foro.