¡Bienvenid@ a Mundo Maker!

¿Quieres aprender todo sobre el RPG Maker?



Regístrate y forma parte de Mundo Maker.
Conectarse

Recuperar mi contraseña

Temas importantes
----------------------------------------
Páginas con recursos RPG Maker
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
Afiliados
Estadísticas
Tenemos 3391 miembros registrados.
El último usuario registrado es Ryu.

Nuestros miembros han publicado un total de 79781 mensajes en 11252 argumentos.
Navega con Google Chrome
[DESCARGA]

Problema con Overlay [VX Ace]

 :: RPG Maker :: Ayuda RPG

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 12:09

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Hace poco probé a crear mapas con el método de "Parallax" para más realismo y no he tenido ningún problema.
Ahora estoy con el método de "Overlay" para que las salas sean aún más realistas, pero tengo un problema...
Cuando muevo el jugador, la capa overlay se mueve con él y se me descoloca, y no queda nada bien.
------------------------------------------------------------------------------------------------------------------------------------------------------------------
• Cuando no me muevo (está todo perfecto, todo colocado perfectamente)


------------------------------------------------------------------------------------------------------------------------------------------------------------------
• Cuando me muevo [se descolocan las capas de overlay que tenía (cajas, paredes, marcos, plantas...)]


------------------------------------------------------------------------------------------------------------------------------------------------------------------
Utilizo la versión de RPG Maker VX Ace; espero que haya alguna manera de solucionar este error... ¡Gracias!


Última edición por KelvMaker el 2015-07-07, 12:57, editado 4 veces

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Bleuw el 2015-07-07, 12:15

¿Utilizás algún script para esto? En tal caso ¿Cual?

Bleuw
Aventurero
Aventurero

0/3

Créditos 1597

Gracias : 101

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 12:21

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Bleuw escribió:¿Utilizás algún script para esto? En tal caso ¿Cual?
                 No, no utilizo ninguno... tengo el juego por defecto, sin scripts añadidos.
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Para poner la capa de overlay sobre el mapa lo que hago es:
- Importo la capa a "Graphics/Pictures" (dentro del Gestor de Recursos).
- Creo un evento en la sala ("Mostrar Imagen" > "Gráfico de Imagen")
- Selecciono la imagen, y en el activador del evento selecciono "Proceso Paralelo".
------------------------------------------------------------------------------------------------------------------------------------------------------------------


Última edición por KelvMaker el 2015-07-07, 12:58, editado 1 vez

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Bleuw el 2015-07-07, 12:34

Por lo que yo sé (Que alguien me corrija si no) al usar imágenes, éstas se usan directamente sobre la pantalla visible, no sobre el mapa. Es decir, que te va a seguir siempre.

Hay un script que te arregla eso, si te interesa, y es éste que te dejo abajo. Que te permite dejar la imagen clavada donde quieras, sin que siga al personaje o fijarla en las coordenadas que gustes.

http://rmrk.net/index.php?topic=44837.0

Bleuw
Aventurero
Aventurero

0/3

Créditos 1597

Gracias : 101

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 12:48

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Bleuw escribió:Por lo que yo sé (Que alguien me corrija si no) al usar imágenes, éstas se usan directamente sobre la pantalla visible, no sobre el mapa. Es decir, que te va a seguir siempre.
Hay un script que te arregla eso, si te interesa, y es éste que te dejo abajo. Que te permite dejar la imagen clavada donde quieras, sin que siga al personaje o fijarla en las coordenadas que gustes.
------------------------------------------------------------------------------------------------------------------------------------------------------------------
¿Me podrías ayudar? La verdad es que no entiendo muy bien las instrucciones para solucionar el fallo.
Tengo que colocar el script debajo de "Material" pero encima de "Main"; hasta ahí todo correcto.
Pero no entiendo que tengo que hacer después, no entiendo lo que dice de los interruptores ni lo de "x" e "y".
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Soy bastante nuevo en esto de RPG Maker y todavía tengo que aprender mucho y no entiendo muchas cosas...
Así que si puedes explicármelo con pelos y señales te lo agradecería mucho, ya que soy muy muy noob.^^
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Bleuw el 2015-07-07, 15:36

No te preocupes.
Lo que tenés que hacer, es...
En la línea 62, que deberías ver algo así
Código:
SWITCH_ID = 321321321
Es el ID del interruptor que tenés que activar para que las imágenes etén quietas. Así de simple, activado quietas, desactivado te siguen.
Donde yo puse 321321321, podés poner el número del interruptor que vos quieras. Yo, en mi caso, por ejemplo, uso el 499.

Saludos.

Bleuw
Aventurero
Aventurero

0/3

Créditos 1597

Gracias : 101

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 16:00

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Soy muy muy nuevo en esto de RPG Maker, así que si pudieras explicármelo mejor te lo agradecería mucho
porque sigo sin solucionar el error. Lo que hice fue: pegar el script que me mandastes en una nueva sección
debajo de "Materials" pero encima de "Main"; luego fui a la línea 62, cambié la ID por 499 (como haces tú) y ya.
Aún así, me sigue sin funcionar... ¿debo hacer algún otro paso antes?
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Nunca he usado nada de interruptores, hasta el momento sólo me he dedicado al map making y nada más.
Si puedes explicarme mejor ese paso de los interruptores perfecto, porque no entiendo ese paso...

De todas maneras, muchas gracias por intentar ayudarme, te lo agradezco... y perdona que sea tan novato.
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Bleuw el 2015-07-07, 16:11

Yo puse 499, como podría ser cualquier otro, puede ser 20 o el que quieras. Mejor un número bajo, pero como yo tengo interruptores ya usado,s pues puse un número alto al azar.

Es simple, crea un evento que active el interruptor y ya.

Bleuw
Aventurero
Aventurero

0/3

Créditos 1597

Gracias : 101

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 16:28

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Nada, sigo sin ser capaz... no entiendo por qué; y mira que lo he intentado.
Creo que he hecho todo igual que tú, hasta he puesto la misma ID para no tenga ningún fallo por intentar variar.
Te pongo una foto del script, y otra del interruptor, para que veas si tengo algún fallo o algo he hecho mal..

http://i60.tinypic.com/machl2.png
http://i62.tinypic.com/awojkj.png
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Miky Joe el 2015-07-07, 16:30

Busca en la sección de emgine y tutoriales...ahí hice unos tutos de parallax...a lo mejor puede que te ayude..

Miky Joe
Veterano
Veterano

0/3

Créditos 525

Gracias : 58

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 17:06

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Miky Joe escribió:Busca en la sección de emgine y tutoriales...ahí hice unos tutos de parallax...a lo mejor puede que te ayude..
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Con Parallax no tengo ningún problema, es al utilizar los "Overlays", que se mueven junto con el personaje.
Las capas overlays son esas donde los objetos están por delante del personaje, luces, sombras, clima...)
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Miky Joe el 2015-07-07, 18:24

SI,LO SE,yo hice un tuto hace mucho de lo mismo,que se usa una picture para lo que va por encima,hice un tuto con script y uno sin script,con un panorama y una picture,pero a diferencia del tuto,no se mueve nada....a lo mejor tiene que ver el tamaño de la picture...no se...

Miky Joe
Veterano
Veterano

0/3

Créditos 525

Gracias : 58

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-07, 20:09

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Miky Joe, te dejo aquí las imágenes "Parallax" y "Overlay" que he creado para mi mapa, para que las utilices tú y a ver si a tí te da el mismo problema, o también puedes intentar encontrar el fallo en las imágenes, aunque creo que están bien.

• Imagen Parallax: http://i58.tinypic.com/nz10dv.png
• Imagen Overlay: http://i62.tinypic.com/z63c7.png

Los objetos pasables son estos(http://goo.gl/enfBGy, utiliza la imagen de rguía, no tiene la misma medida)
La sala es de 17x14 (y ambas fotos de 544x448, están creadas con Photoshop y son archivos .png).
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Miky Joe el 2015-07-07, 22:33

Pues mira....hice la prueba que tanto querias...
y mira lo que paso.

Aqui:

Solo puse comando mostrar imagen 5...despues borrar evento,esto en inicio automatico y no en paralelo,asi como en el tuto de parallax-image...obiamente tu al cambiar de mapa debes de nostrar la imagen de cada mapa...osea,si mapa 1 es imagen 1....cuando cambies de mapa le das a mapa 2,(En el teletrasnporte)borrar imagen 1,y mostrar imagen 2,aparte del parallax para cada mapa,y asi lo hice y asi funciono sin ningun error.
Creo que el unico error de no usar script....seria que cuando pones el comando de cambio de tono de pantalla,solo cambia la tonalidad el parallax y no la imagen.

Espero y me hayas entendido en algo tan sencillo.

Saludos

Miky Joe
Veterano
Veterano

0/3

Créditos 525

Gracias : 58

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por KelvMaker el 2015-07-08, 14:17

------------------------------------------------------------------------------------------------------------------------------------------------------------------
Miky Joe escribió: Pues mira. hice la prueba que tanto querias... y mira lo que paso
Espero y me hayas entendido en algo tan sencillo, saludos.
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Probé a hacerlo con tu método, poniendo en modo "Automático" con 5 números; pero nada.
El problema es que lo hicistes con 17x13 (las medidas mínimas) y con esas siempre me funciona...
El error me aparece cada vez que hago un mapa más grande que esas medidas (en este caso, 17x14).
Prueba de nuevo a hacerlo con 17x14 y dime si te funciona, no hace falta que grabes un vídeo.

De todas maneras te doy las gracias por intentar ayudarme y hacer un vídeo para que sea más fácil.
Seguiré buscando en Internet y en otros foros a ver si encuentro algo, porque no entiendo qué pasa...^^
------------------------------------------------------------------------------------------------------------------------------------------------------------------

KelvMaker
Iniciado
Iniciado

0/3

Créditos 13

Gracias : 2

Volver arriba Ir abajo

Re: Problema con Overlay [VX Ace]

Mensaje por Contenido patrocinado Hoy a las 20:17


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 :: RPG Maker :: Ayuda RPG

Permisos de este foro:
No puedes responder a temas en este foro.