¡Bienvenid@ a Mundo Maker!

¿Quieres aprender todo sobre el RPG Maker?



Regístrate y forma parte de Mundo Maker.
Conectarse

Recuperar mi contraseña

Temas importantes
----------------------------------------
Páginas con recursos RPG Maker
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
----------------------------------------
Últimos temas
» Necesito Script
por Elian84 Hoy a las 04:44

» Holaaa a tod@s!!!
por chronoMxx Hoy a las 03:41

» [AYUDA]Hootshot de moghunter
por Rudy_kinneas Hoy a las 01:06

» El poder oculto (Segunda entrega)
por alex1633 Ayer a las 23:18

» Tutorial Interactivo [Uso de interruptores]
por alex1633 Ayer a las 19:39

» Hola mucho gusto
por Hk Diamond Ayer a las 13:49

» SoraDeathss se presenta!
por chronoMxx Ayer a las 07:50

» {AYUDA}Blizz-ABS Script
por chronoMxx Ayer a las 06:45

» las cosas como son...
por Bleuw Ayer a las 04:18

» Busco artistas graficos para proyecto serio
por Rudy_kinneas 2016-12-02, 20:52

Afiliados
Estadísticas
Tenemos 3381 miembros registrados.
El último usuario registrado es Hk Diamond.

Nuestros miembros han publicado un total de 79767 mensajes en 11247 argumentos.
Navega con Google Chrome
[DESCARGA]

[RMVXACE] Problema al mover evento.

 :: RPG Maker :: Ayuda RPG

Ver el tema anterior Ver el tema siguiente Ir abajo

[RMVXACE] Problema al mover evento.

Mensaje por Sayui el 2014-05-17, 22:51

Buenas, el caso es que he intentado realizar un engine, en el que cuando el heroe toca el evento, este último se mueva varios espacios hacia la izquierda.

El problema, es que a pesar de que tiene puestos dos desplazamientos a la izquierda, solo se mueve un único espacio en esa dirección. La única manera en la que he conseguido que se mueva correctamente es al poner Esperar a que finalice el movimiento.

-Me gustaría poder hacerlo sin tener que impedir que el heroe se pueda mover. ¿Es posible?

-En caso de que no lo sea, agradecería si me pudierais explicar a que se debe ésta diferencia. Llevo desde el viernes intentándolo y sigo sin entenderlo.

Gracias y disculpad las molestias.

Sayui
Iniciado
Iniciado

0/3

Créditos 29

Gracias : 3

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por rpgmanumaker el 2014-05-17, 23:29

Pues no se me ocurre que puede estar pasando. Acabo de hacer un mini-engine con lo que has dicho. He creado un engine que se active al ser tocado por el héroe y dentro de ese engine un ruta de movimiento para ese evento que diga que se mueva dos veces a la izquierda... y ha funcionado bien.

Si otra persona no te puede ayudar mejor, quizás convendría que subas la carpeta en la cual estás haciendo el juego, para ver que puede estar pasando

También te recomiendo que pruebes el engine en un nuevo juego, para ver si funciona.

rpgmanumaker
Veterano
Veterano

1/3

Créditos 678

Gracias : 23

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por orochii el 2014-05-18, 00:32

Quiza si nos pasaras una captura de pantalla de lo que has hecho. Porque tengo una ligera sospecha de qué puede estar pasando...

orochii
Caballero Shiro
Caballero Shiro

0/3

Créditos 6045

Gracias : 266

http://drekirokr.weebly.com/

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por Sayui el 2014-05-18, 01:02

Aqui pongo las imagenes, y muchas gracias por responder tan rapido =).

http://oi57.tinypic.com/2ng6d8k.jpg

El evento en cuestion, es la esfera, que al pisarla deberia desplazarse dos posiciones a la izquierda, y a continuacion, activar el Self-switch A para que pase a la siguiente hoja del evento.

http://oi62.tinypic.com/2zf3bk5.jpg

El problema es, que en lugar de moverse dos espacios, solo se movia uno, hasta que active el "Esperar hasta que termine el movimiento" solo entonces se mueve los dos espacios.

http://oi60.tinypic.com/15cngio.jpg

En la pestaña dos no le he puesto el esperar a posta, y lo dicho, en lugar de moverse dos veces a la derecha se mueve uno.

Sayui
Iniciado
Iniciado

0/3

Créditos 29

Gracias : 3

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por orochii el 2014-05-18, 01:31

Aaaah sí, creo que lo que detiene la bola es el cambio de página. ¿Qué tal si lo haces así?

Tú pruébalo, porque creo que hay un bug importante, que es que como ahora el héroe se puede mover, si vas y persigues a la bola y le spammeas Z, se empieza a mover pa todo lado xD.

orochii
Caballero Shiro
Caballero Shiro

0/3

Créditos 6045

Gracias : 266

http://drekirokr.weebly.com/

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por rpgmanumaker el 2014-05-18, 01:34

activa el interruptor local desde el mover evento. O sea, desde donde indicas que se mueva el evento a la izquierda, debe de haber un comando para activar o desactivar interruptores locales, usa esos comando para activar el interruptor local A. De esa manera, debería de funcionar.

Verás, creo que pasa lo siguiente: Cuando usas el comando mover evento, sin la opción de esperar a que termine marcada, el programa sigue con el engine. O sea, empieza a mover el evento, pero también continúa con lo que haya debajo del comando mover evento. Y en este caso, lo que hay es una activación de interruptor local. Cuando el interruptor se activa, al comando mover evento no le ha dado tiempo de ejecutar la segunda opción, así que cambia de página sin que dé el segundo paso a la izquierda. Por eso, cuando marcas la casilla de esperar a que el comando mover evento termine, te funciona el engine. Dado que con esa casilla marcada, primero se hacen los movimientos y luego continúa el engine, en este caso, activar el interruptor local.

Si haces lo que te he mencionado arriba, activar el engine mediante el comando mover evento, después de los dos mover a la izquierda, debería de funcionar aunque no esté marcada la casilla esperar a que termine.

PD: Creo que me he equivocado, parece que no se pude activar interruptores locales desde el comando mover evento, de ser así, haz lo que te explicó Orochii, es sencillo y funcional.

rpgmanumaker
Veterano
Veterano

1/3

Créditos 678

Gracias : 23

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por Sayui el 2014-05-18, 02:11

Muchas gracias a ambos. Pues al parecer, si era el cambio de pagina. He estado haciendo unas pruebas, y parece que el cambio se da justo al terminar la primera accion de desplazamiento.

Muchas gracias por la explicacion a ambos :). Lo hare tal como dijo Orochii. 

Sayui
Iniciado
Iniciado

0/3

Créditos 29

Gracias : 3

Volver arriba Ir abajo

Re: [RMVXACE] Problema al mover evento.

Mensaje por Contenido patrocinado Hoy a las 06:09


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba


 :: RPG Maker :: Ayuda RPG

Permisos de este foro:
No puedes responder a temas en este foro.